Thursday, April 19, 2012

Multicast TroubleShooting

Configuration of Multicast is not that difficult unlike its troubleshooting. The multicast TS is a process of verifying the configuration at each step using proper tools. Lets take a multicast TS ticket which involves an advance multicast scenario with multiple issues which may not necessarily only from multicast.
You just need to copy and paste the initial configuration on all the devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes 

Topology Diagram:




Ticket: R6 can not able to ping the multicast group 224.2.2.2 which is listening on R2's Loopback0. Fix it.


--------------------------INITIAL CONFIGURATIONS---------------------------------


R1:

enable
config t




Current configuration : 942 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!      
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------

R2:

enable
config t



Current configuration : 1567 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
 ip pim sparse-mode
 ip igmp join-group 224.2.2.2
 no ip mroute-cache
!
interface FastEthernet0/0
 ip address 155.1.28.2 255.255.255.0
 ip pim sparse-mode
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 shutdown
!
router eigrp 10
 network 150.1.2.2 0.0.0.0
 network 155.1.28.2 0.0.0.0
 no auto-summary
 eigrp router-id 150.1.2.2
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 150.1.2.0 mask 255.255.255.0
 neighbor 150.1.8.8 remote-as 200
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip pim send-rp-announce Loopback0 scope 2 interval 10
ip msdp peer 150.1.3.3 connect-source Loopback1 remote-as 101
ip msdp password peer 150.1.3.3 CISC0
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------

R3:

enable
config t


Current configuration : 1918 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
 ip pim sparse-mode
 shut
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.39.3 255.255.255.0
 ip pim sparse-mode
 ip access-group MULTICAST in
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!      
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 router-id 150.1.3.3
 log-adjacency-changes
 network 150.1.3.3 0.0.0.0 area 1
 network 155.1.37.3 0.0.0.0 area 1
 network 155.1.39.3 0.0.0.0 area 1
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 150.1.3.0 mask 255.255.255.0
 neighbor IBGP_PEERS peer-group
 neighbor IBGP_PEERS remote-as 100
 neighbor IBGP_PEERS update-source Loopback0
 neighbor IBGP_PEERS route-reflector-client
 neighbor 150.1.7.7 peer-group IBGP_PEERS
 neighbor 150.1.9.9 peer-group IBGP_PEERS
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip pim rp-candidate Loopback0 interval 10
ip msdp peer 150.1.2.2 connect-source Loopback0
ip msdp password peer 150.1.2.2 CISCO
!
access-list 120 permit ip 155.1.56.0 0.0.0.255 225.0.0.0 30.255.255.255
!
!
ip access-list extended MULTICAST
 deny   pim any any
 permit ip any any
!
!
!
!
control-plane
!
!      
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------

R4:

enable
config t




Current configuration : 962 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!      
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end


---------------------------------------------------------------------------------------------

R5:

enable
config t


Current configuration : 1346 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 155.1.56.5 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.59.5 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 shutdown
!      
router ospf 1
 router-id 150.1.5.5
 log-adjacency-changes
 area 2 nssa default-information-originate
 network 150.1.5.5 0.0.0.0 area 0
 network 155.1.56.5 0.0.0.0 area 2
 network 155.1.59.5 0.0.0.0 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip pim bsr-candidate Loopback0 0
!
!
!
!
!
!
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------

R6:

enable
config t



Current configuration : 1147 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
ip multicast-routing
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.56.6 255.255.255.0
 ip pim sparse-mode
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
router ospf 1
 router-id 150.1.6.6
 log-adjacency-changes
 area 1 nssa
 network 150.1.6.6 0.0.0.0 area 2
 network 155.1.56.6 0.0.0.0 area 1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------

SW1:

enable
config t



Current configuration : 4742 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
!
!      
ip multicast-routing distributed
!
!
crypto pki trustpoint TP-self-signed-3817290112
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290112
 revocation-check none
 rsakeypair TP-self-signed-3817290112
!
!
crypto pki certificate chain TP-self-signed-3817290112
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393031 3132301E 170D3933 30333031 30303031
  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303131 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BB1A 34F6E38D F58112CD 9746C936 56896227 89935549 C3EB868B 7DA4FA9A
  D0FB19AD 6A3B56CA 082ED34C 2535742C 0B553966 5B3F62E4 6690AE4E ACF20A55
  3006A862 5054DA8C 69E91CB3 3BBF2E1D CDC0B840 A0D95D49 D9B30BB6 2649739A
  D4B6F4E9 3B8901F4 6AB02F0E 99DA0F8E 5F66A89C E85164E2 BD84FB08 F8A7702E
  025B0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535731 2E301F06 03551D23 04183016 80144E36 D63150BB
  D68858CA 720B4CDC 392B8564 5D4F301D 0603551D 0E041604 144E36D6 3150BBD6
  8858CA72 0B4CDC39 2B85645D 4F300D06 092A8648 86F70D01 01040500 03818100
  3ED41F07 B919C329 58A5E77A B2E7F84C 479E10DA 20D41836 895A083D C3A299EE
  FC134E4E D53F35B3 E31CECAD CF775040 A8586B76 736C58FC 7EB9EEB8 BF6E8998
  A11BA823 DBC19B14 D4C9E070 AA030C83 0C9EFB4B 848C8F16 B2A0DB75 26E07011
  AAFCF349 D8CE11C7 6C740FA7 B072ED71 3C058778 B353D9EF 538AE575 BFE15FF6
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.7.7 255.255.255.0
!      
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 56
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!      
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!      
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan78
 ip address 155.1.78.7 255.255.255.0
 ip pim bsr-border
!
router ospf 1
 router-id 150.1.7.7
 log-adjacency-changes
 network 150.1.7.7 0.0.0.0 area 1
 network 155.1.37.7 0.0.0.0 area 1
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 150.1.3.3 remote-as 100
 neighbor 150.1.3.3 next-hop-self
 neighbor 155.1.78.8 remote-as 200
 no auto-summary
!
ip classless
ip http server
ip http secure-server
!
!
!      
ip prefix-list R6_PREFIX seq 5 permit 155.1.56.0/24
ip prefix-list R6_PREFIX seq 10 permit 150.1.6.0/24 ge 32
ip sla enable reaction-alerts
!
route-map R6_PREFIX->BGP permit 10
 match ip address prefix-list R6_PREFIX
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line vty 0 4
 login
line vty 5 15
 login
!
end


---------------------------------------------------------------------------------------------

SW2:

enable
config t



Current configuration : 4672 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
!
!      
ip multicast-routing distributed
!
!
crypto pki trustpoint TP-self-signed-3819482240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3819482240
 revocation-check none
 rsakeypair TP-self-signed-3819482240
!
!
crypto pki certificate chain TP-self-signed-3819482240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383139 34383232 3430301E 170D3933 30333031 30303031
  32305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313934
  38323234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BA8A 91B9F34F 61EF5C72 0A769170 C145F085 B9A4301B 5F5CA957 80BA7085
  7D18D125 8985C8DE BDEEF751 3CB3D694 EBDF7F6F 79EC952E D4636C37 2FC460C0
  55A6C402 46507722 9D5D8E0E 7B8676A6 29E264F2 D997B654 C8D62F05 95ADCFBE
  B48722F3 240BFF79 36D840CB 831851A2 05A94C24 84044E64 21C3B002 3060C2E0
  E79D0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 801491E5 622F7489
  F097DA15 89997FA9 46705116 8E08301D 0603551D 0E041604 1491E562 2F7489F0
  97DA1589 997FA946 7051168E 08300D06 092A8648 86F70D01 01040500 03818100
  4347DB03 09EC1E15 AB1B079E 870EDC8D 15D982C0 CA00E679 3C051E1E B0CA9D4F
  52C98D65 29954E0B C145D907 D370946C A8748B05 A6F816D4 C9EC2961 115F003A
  07251756 F72D444B 9DF962AC 2E93C8D0 070870EB 17CAE0AA E0023412 5C8787F8
  85E06849 24E7FA5B 2D46535C 031AD148 57A40C87 4BC401F2 8257D98E A3A7F904
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.8.8 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 no switchport
 ip address 155.1.28.8 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport access vlan 56
 switchport mode access
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan78
 ip address 155.1.78.8 255.255.255.0
 ip pim sparse-mode
 ip multicast boundary FILTER_AUTO_RP
!
!
router eigrp 10
 network 150.1.8.8 0.0.0.0
 network 155.1.28.8 0.0.0.0
 eigrp router-id 150.1.8.8
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 150.1.2.2 remote-as 200
 neighbor 150.1.2.2 update-source Loopback0
 neighbor 150.1.2.2 next-hop-self
 neighbor 155.1.78.7 remote-as 100
 no auto-summary
!
ip classless
ip http server
ip http secure-server
!
!
access-list 2 permit 150.1.2.2
access-list 22 deny   224.0.0.0
access-list 22 permit any
!
ip pim send-rp-discovery Loopback0 scope 1 interval 10
ip pim rp-announce-filter rp-list 2 group-list 22
!      
ip access-list standard FILTER_AUTO_RP
 deny   224.0.1.39
 deny   224.0.1.40
 permit any
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line vty 0 4
 login
line vty 5 15
 login
!
end

---------------------------------------------------------------------------------------------

SW3:

enable
config t


Current configuration : 4547 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW3
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
!
!      
!
!
crypto pki trustpoint TP-self-signed-3817305984
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817305984
 revocation-check none
 rsakeypair TP-self-signed-3817305984
!
!
crypto pki certificate chain TP-self-signed-3817305984
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 33303539 3834301E 170D3933 30333031 30303031
  32305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313733
  30353938 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100E9D9 7ABD3879 0A129780 9F334565 356A9FF4 EB7FE4E1 34ACDAE2 B4F64E4D
  1001A812 964DB2EC 0F3F774F 98D9D043 6F68F370 26FB3FD4 B2C25E37 5E1FB5C1
  5B7DF79A 22FCD48A 1248FD23 07DDB4EC 916FD70D FFD59E03 09F0B545 5736A864
  56674F5B 67F7FB60 CE98BBDB 3137C54C 5EDA5B3E C9457CC8 3C316909 2166027C
  E64F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535733 2E301F06 03551D23 04183016 8014A185 28641084
  A83336D4 F35DB110 90343537 8FC2301D 0603551D 0E041604 14A18528 641084A8
  3336D4F3 5DB11090 3435378F C2300D06 092A8648 86F70D01 01040500 03818100
  93EB266A 7147D6E0 10B4777B 490685E8 07A6761E 2D312478 0F546501 BB218280
  E67897F8 10B68BF4 FE6D5F2B AEA2565F 39380FF3 E2C0E351 AFCE0794 8F837E30
  0013685F 6A08D572 4363A817 85B2EBF0 2C5ADFA1 8966D9F6 8E27C721 A5E76140
  DA72BE7A 3F405FFA 16C5B456 4CA0E0F8 4F7D45CB BB8F205E D6CA4577 6054FB6A
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.9.9 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 39
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 59
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!      
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!      
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan39
 ip address 155.1.39.9 255.255.255.0
 ip pim sparse-mode
!      
interface Vlan59
 ip address 155.1.59.9 255.255.255.0
 ip pim sparse-mode
!
router ospf 1
 router-id 150.1.9.9
 log-adjacency-changes
 network 150.1.9.9 0.0.0.0 area 0
 network 155.1.39.9 0.0.0.0 area 1
 network 155.1.59.9 0.0.0.0 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 150.1.3.3 remote-as 100
 no auto-summary
!
ip classless
ip http server
ip http secure-server
!
ip pim rp-candidate Loopback0 interval 10 priority 100
!      
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line vty 0 4
 login
line vty 5 15
 login
!
end

---------------------------------------------------------------------------------------------

SW4:

enable
config t



Current configuration : 3838 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW4
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
!
!
!      
!
crypto pki trustpoint TP-self-signed-3817290240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290240
 revocation-check none
 rsakeypair TP-self-signed-3817290240
!
!
crypto pki certificate chain TP-self-signed-3817290240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393032 3430301E 170D3933 30333031 30303031
  31395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C7F8 FD003D7F 48BF2D79 D2E2F3AF 97BF626A 2482A978 D6E7C205 F9C354A9
  2593DBE7 5C88F699 6DDF93D1 48D951A1 8491A61A B76B8155 C6E15C7B 20304EF8
  39DAA4ED 518F5B1C 4DA8D48B E5E92163 01EFA14A 934BECDF F5929DF4 341C6BD5
  6CC94434 C6B1F2E7 CE01FF1A 6EB9861E FC20B52F FEA94C23 0BAB1BCD A0936845
  AF930203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535734 2E301F06 03551D23 04183016 80149123 050BF20B
  50FE9784 F4AE992E 61D66F3D 3DB8301D 0603551D 0E041604 14912305 0BF20B50
  FE9784F4 AE992E61 D66F3D3D B8300D06 092A8648 86F70D01 01040500 03818100
  405838B4 838FD607 9BFFB10B B8E8EFC1 13F2555A F0914056 E33565C5 FE3928CC
  C1A846A7 A93899F5 A6D5BB09 BD4A4756 0FDCBB73 2CDCD171 2B6520CD 6665BD32
  769A6895 102656AE 1515A7B7 ADBABED2 22A4AD16 C193B70D 20814864 DCBD06D6
  29CF765D 0B28932D F73F5513 0A2BC8EC 88D37371 10DA44FC 94A0356D 39C5CB6A
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/15
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/16
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/17
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/18
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/19
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport nonegotiate
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line vty 0 4
 login
line vty 5 15
 login
!
end

---------------------------------------------------------------------------------------------