Wednesday, April 18, 2012

NTP TroubleShooting

NTP provide time synchronization in the network devices. NTP TS its just like verifying each configuration steps except with minor exceptions. Lets take those exceptions along with common causes in NTP TS.  I deliberately introduce multiple issues in this topology. These issues may not necessarily be from NTP.
You just need to copy and paste the initial configuration on all the devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes

Topology Diagram:

Ticket1: NTP clients are not synchronized with NTP server. Fix it.

-----------------------INITIAL CONFIGURATIONS-------------------------------

R1:

Enable
Config t



Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.1 255.255.255.0
 frame-relay interface-dlci 105
!      
interface Serial0/0/1
 ip address 155.1.13.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!      
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------



R2:

Enable
Config t




Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.2 255.255.255.0
 frame-relay interface-dlci 205
!
interface Serial0/0/1
 ip address 155.1.23.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

----------------------------------------------------------------------------------------


R3:

Enable
Config t




Current configuration : 1878 bytes
!
! Last configuration change at 20:44:30 UTC Wed Apr 18 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!      
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!      
!
!
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 ip access-group EIGRP in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.43.3 255.255.255.0
 ip access-group NTP in
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.3 255.255.255.0
 frame-relay interface-dlci 305
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 clock rate 64000
!
interface Serial1/3
 ip address 155.1.23.3 255.255.255.0
 clock rate 64000
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!      
!
!
ip access-list extended EIGRP
 permit ip any any
ip access-list extended NTP
 deny   udp any eq ntp any
 deny   udp any any eq ntp
 permit ip any any
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!      
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
ntp authentication-key 43 md5 096F673A3A2A 7
ntp authenticate
ntp trusted-key 43
ntp server 150.1.4.4 source Loopback0
end

-----------------------------------------------------------------------------------------


R4:

Enable
Config t




Current configuration : 1759 bytes
!
! Last configuration change at 20:42:18 UTC Wed Apr 18 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!      
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
key chain EIGRP
 key 1
   key-string CISCO
!
!
!
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!      
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
 shutdown
!
interface FastEthernet0/0
 ip address 155.1.43.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.4 255.255.255.0
 frame-relay interface-dlci 405
!
interface Serial0/0/1
 ip address 155.1.45.4 255.255.255.0
 clock rate 64000
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!      
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
ntp authentication-key 43 md5 00273A352774 7
ntp authentication-key 46 md5 047822352C0E 7
ntp trusted-key 64
ntp trusted-key 43
ntp source Loopback0
ntp master 7
ntp server 150.1.4.4
end

-----------------------------------------------------------------------------------------


R5:

Enable
Config t





Current configuration : 1398 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.58.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.5.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.0.4 504 broadcast
 frame-relay map ip 155.1.0.3 503 broadcast
 frame-relay map ip 155.1.0.2 502 broadcast
 frame-relay map ip 155.1.0.1 501 broadcast
 no frame-relay inverse-arp
!
interface Serial0/0/1
 ip address 155.1.45.5 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------


R6:

Enable
Config t





Current configuration : 1692 bytes
!
! Last configuration change at 20:45:14 UTC Wed Apr 18 2012
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!      
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
key chain EIGRP
 key 1
   key-string CISCO
!
!
!
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!      
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
!
interface FastEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 54.1.1.254 101 broadcast
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!      
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
ntp authentication-key 46 md5 062526136F61 7
ntp authenticate
ntp server 150.1.4.4 source Loopback0
end

---------------------------------------------------------------------------------------


SW1:

Enable
Config t




Current configuration : 4010 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-3817290112
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290112
 revocation-check none
 rsakeypair TP-self-signed-3817290112
!
!
crypto pki certificate chain TP-self-signed-3817290112
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393031 3132301E 170D3933 30333031 30303131
  30325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303131 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100EB14 D8B1EDD2 7907520B 10C018D4 39F0AD6D A231AED9 BED9AEC6 21A79CDC
  7D4DC350 94F3AAA1 FD77B225 13996685 B8946D64 2E7B3189 2BD0F2E0 F9447FDA
  599B426C DEF0AC03 4CC22373 D2C0CFE8 A9D14CFF 0067B2F1 5AACD311 1BC493BC
  988BD25F 7C38F0DD 618E2B94 F6E984B6 E2266F69 4AF3DFDB B0A9B719 331A612B
  90E30203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535731 2E301F06 03551D23 04183016 8014DA7A D70513B1
  129D9908 816E0E58 FA147A8F A3BD301D 0603551D 0E041604 14DA7AD7 0513B112
  9D990881 6E0E58FA 147A8FA3 BD300D06 092A8648 86F70D01 01040500 03818100
  9A0A702B AB8CAC50 D7C3F588 6E4FD437 A28C3809 A55F99F4 D289059C 000097FA
  ED0E328F D3F79F77 85B2C6BD B078E7BC B55D17F4 AB8DF5BA 810C8DAC 4CBBE939
  70C9FB6E EAEFD9CB 3BC77A03 805E7037 7ECC12C3 F5DE5101 6D776B23 4B963D65
  67BBDED5 BAF9A4E2 DFDDE663 31841423 1C753ECB BEAED509 25149EEC 0681E588
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.7.7 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 58
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!      
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan7
 ip address 155.1.7.7 255.255.255.0
!
interface Vlan67
 ip address 155.1.67.7 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.7 255.255.255.0
!
!
router eigrp 10
 network 155.1.0.0
 network 150.1.0.0
 no auto
!
!
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end
       

-----------------------------------------------------------------------------------------


SW2:

Enable
Config t




Current configuration : 4060 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3819482240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3819482240
 revocation-check none
 rsakeypair TP-self-signed-3819482240
!
!
crypto pki certificate chain TP-self-signed-3819482240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383139 34383232 3430301E 170D3933 30333031 30303131
  30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313934
  38323234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A837 82D6C881 800C4388 3530AB13 BA5BF24E 287B930D 23E87550 2AB8E6CE
  D2A64706 F0D4D7F8 F0D6A957 99618333 41B3151E 0D4A3762 D23C6B90 255500D5
  BCEDFFCE E5BD2B0C 18824191 41DC2C91 65C0B10B C80DA935 6B640AB4 3AFCB936
  CB3EF1E6 6D89E7EE 16248E2E 66E19965 D299D3D7 C399BA9F A451A94B 15C8D1CC
  428F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 8014D981 2DC83174
  778DE36B ED56E7EA 12238458 C0AB301D 0603551D 0E041604 14D9812D C8317477
  8DE36BED 56E7EA12 238458C0 AB300D06 092A8648 86F70D01 01040500 03818100
  1D070628 97289B70 5232CF0F 90385491 EF2D1BE2 0727752A 26372174 9BFF2D8E
  48393ABB D1CFFFD3 3A3DD0F4 4129CC11 9889BD50 E34102AD 73D3350B 8AAED219
  CD2BA90C 27F10D8A A886305D D4FAE4D9 CFB58DFF A48F8A69 27794E02 CF2144EA
  EFCED9F0 6CFDFE4C 9CAE7CF0 97459580 093DC01C 35AB8559 4D0B04E0 40644CB3
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
ip access-list extended EIGRP
 permit eigrp any any
!
!
vlan access-map VLAN_MAP 10
 action drop
 match ip address EIGRP
vlan access-map VLAN_MAP 20
 action forward
!
vlan filter VLAN_MAP vlan-list 43
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.8.8 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.8 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/20
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!      
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan8
 ip address 155.1.8.8 255.255.255.0
!
interface Vlan58
 ip address 155.1.58.8 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

---------------------------------------------------------------------------------------



SW3:

Enable
Config t



Current configuration : 3831 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817305984
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817305984
 revocation-check none
 rsakeypair TP-self-signed-3817305984
!
!
crypto pki certificate chain TP-self-signed-3817305984
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 33303539 3834301E 170D3933 30333031 30303131
  30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313733
  30353938 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C769 FF6EFF61 B1A90633 742490B5 451DB6A8 FD3ECCEB D50F2A27 06A6ED45
  FE139569 A086D8B8 41C65CE6 94E798C7 A8DF051A 517916F6 FB95380A E47BFE44
  DDDB9A60 8ACEB1F7 CDA47FB2 6939B9D8 A6E3BF7C B824AC58 1519707F 018A6806
  9C246CFF 3C6A817F 2FFF8376 D496A0F6 606E7E0C F161678C A92800A1 DE884A97
  545F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535733 2E301F06 03551D23 04183016 8014727E F9FC8A5B
  863BBB1E BC2C115F 813F4BFC 9EA9301D 0603551D 0E041604 14727EF9 FC8A5B86
  3BBB1EBC 2C115F81 3F4BFC9E A9300D06 092A8648 86F70D01 01040500 03818100
  7AB609CE 03584B9A 85D00FCF 6CA6F59F E4984898 35D53691 6433BF57 A37C3ED1
  4866CBC1 E99C3746 799393CC 95EEE40A DD9F6A51 3F061CCF 3CB59A53 897AF112
  4F135059 01DA2695 3EC6DCAB 4C850371 72404BD0 3C15F2C5 926617EB 047E9D92
  65948CC2 DC676466 1194CB15 364D3665 088ABB44 0E5929DB 2F408387 1A704054
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.9.9 255.255.255.0
!      
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 43
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!      
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan9
 ip address 155.1.9.9 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.9 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

---------------------------------------------------------------------------------------



SW4:

Enable
Config t




Current configuration : 3800 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817290240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290240
 revocation-check none
 rsakeypair TP-self-signed-3817290240
!
!
crypto pki certificate chain TP-self-signed-3817290240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393032 3430301E 170D3933 30333031 30303131
  30325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A882 8FE6CF9A B3F50221 B8E72FCF 63CCCD43 C1A9413D 0FB9A949 7039AF7A
  C388A46C BAD51B80 8FF8E1D9 93117A25 7B3050AE B45DD0F1 BCF4A248 E8E67E26
  C32763D1 EEF76A8C CE39F76C 974AA287 D0822950 BB6ECD51 963A028D 9BD7B103
  E40BCA82 6CDA6BBF 11A9F479 53A4E74C 81B718D7 D02291BF F48444FB F3AE2205
  C8BD0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535734 2E301F06 03551D23 04183016 80141447 F24FD588
  D20BE6F5 CD962442 8F6EB9DA 9579301D 0603551D 0E041604 141447F2 4FD588D2
  0BE6F5CD 9624428F 6EB9DA95 79300D06 092A8648 86F70D01 01040500 03818100
  1CC19729 F5D312B9 DA3B6C4B 5AC0BD06 6317043C 05CF0A2B CDA4F23E 2D0E8A24
  2FB4DBF1 9551F6B2 469A7904 3FC08A0A 997DC725 5B00BDA8 5BA37247 B45E7086
  5CE14049 C1FC95BB F3D2CDC4 F68F8271 F71CED12 B3B0CFB1 658584DC F731F6B8
  7410BA9C E3819D52 4B36A44F B45094CF 669F6B6B 10C6FD9B 173FB472 E424132D
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.10.10 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.10 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!      
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/17
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end


---------------------------------------------------------------------------------------











EIGRP TroubleShooting

EIGRP TS ticket may sometimes create unexpected problems. Lets take an EIGRP Troubleshooting ticket. I deliberately introduce multiple issues in this topology. These issues may not necessarily be from EIGRP.
You just need to copy and paste the initial configuration on concern devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes 

Topology Diagram:

Ticket1:  Loopback0 interfaces of SW1 and R4 are unable to reach each other. Fix it

--------------------------INITIAL CONFIGURATIONS------------------------

R1:


Enable
Config t


Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.1 255.255.255.0
 frame-relay interface-dlci 105
!      
interface Serial0/0/1
 ip address 155.1.13.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!      
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------

R2: 

Enable
Config t




Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.2 255.255.255.0
 frame-relay interface-dlci 205
!
interface Serial0/0/1
 ip address 155.1.23.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end


-----------------------------------------------------------------------------------------------

R3: 

Enable
Config t




Current configuration : 1591 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 ip access-group EIGRP in
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.43.3 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.3 255.255.255.0
 frame-relay interface-dlci 305
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 clock rate 64000
!
interface Serial1/3
 ip address 155.1.23.3 255.255.255.0
 clock rate 64000
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
ip access-list extended EIGRP
 deny   eigrp any any
 permit ip any any
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------

R4:

Enable
Config t




Current configuration : 1375 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.43.4 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.4 255.255.255.0
 frame-relay interface-dlci 405
!
interface Serial0/0/1
 ip address 155.1.45.4 255.255.255.0
 clock rate 64000
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!      
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end


-----------------------------------------------------------------------------------------------

R5: 

Enable
Config t





Current configuration : 1398 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.58.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.5.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 155.1.0.4 504 broadcast
 frame-relay map ip 155.1.0.3 503 broadcast
 frame-relay map ip 155.1.0.2 502 broadcast
 frame-relay map ip 155.1.0.1 501 broadcast
 no frame-relay inverse-arp
!
interface Serial0/0/1
 ip address 155.1.45.5 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------

R6: 

Enable
Config t





Current configuration : 1401 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
!
interface FastEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 54.1.1.254 101 broadcast
!
router eigrp 10
 network 150.1.0.0
 network 155.1.0.0
 auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------

SW1: 

Enable
Config t



Current configuration : 4010 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-3817290112
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290112
 revocation-check none
 rsakeypair TP-self-signed-3817290112
!
!
crypto pki certificate chain TP-self-signed-3817290112
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393031 3132301E 170D3933 30333031 30303131
  30325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303131 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100EB14 D8B1EDD2 7907520B 10C018D4 39F0AD6D A231AED9 BED9AEC6 21A79CDC
  7D4DC350 94F3AAA1 FD77B225 13996685 B8946D64 2E7B3189 2BD0F2E0 F9447FDA
  599B426C DEF0AC03 4CC22373 D2C0CFE8 A9D14CFF 0067B2F1 5AACD311 1BC493BC
  988BD25F 7C38F0DD 618E2B94 F6E984B6 E2266F69 4AF3DFDB B0A9B719 331A612B
  90E30203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535731 2E301F06 03551D23 04183016 8014DA7A D70513B1
  129D9908 816E0E58 FA147A8F A3BD301D 0603551D 0E041604 14DA7AD7 0513B112
  9D990881 6E0E58FA 147A8FA3 BD300D06 092A8648 86F70D01 01040500 03818100
  9A0A702B AB8CAC50 D7C3F588 6E4FD437 A28C3809 A55F99F4 D289059C 000097FA
  ED0E328F D3F79F77 85B2C6BD B078E7BC B55D17F4 AB8DF5BA 810C8DAC 4CBBE939
  70C9FB6E EAEFD9CB 3BC77A03 805E7037 7ECC12C3 F5DE5101 6D776B23 4B963D65
  67BBDED5 BAF9A4E2 DFDDE663 31841423 1C753ECB BEAED509 25149EEC 0681E588
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.7.7 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 58
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!      
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan7
 ip address 155.1.7.7 255.255.255.0
!
interface Vlan67
 ip address 155.1.67.7 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.7 255.255.255.0
!
!
router eigrp 10
 network 155.1.0.0
!
!
router eigrp 1
 network 150.1.7.7 0.0.0.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end
       

-----------------------------------------------------------------------------------------------

SW2: 

Enable
Config t




Current configuration : 4060 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3819482240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3819482240
 revocation-check none
 rsakeypair TP-self-signed-3819482240
!
!
crypto pki certificate chain TP-self-signed-3819482240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383139 34383232 3430301E 170D3933 30333031 30303131
  30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313934
  38323234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A837 82D6C881 800C4388 3530AB13 BA5BF24E 287B930D 23E87550 2AB8E6CE
  D2A64706 F0D4D7F8 F0D6A957 99618333 41B3151E 0D4A3762 D23C6B90 255500D5
  BCEDFFCE E5BD2B0C 18824191 41DC2C91 65C0B10B C80DA935 6B640AB4 3AFCB936
  CB3EF1E6 6D89E7EE 16248E2E 66E19965 D299D3D7 C399BA9F A451A94B 15C8D1CC
  428F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 8014D981 2DC83174
  778DE36B ED56E7EA 12238458 C0AB301D 0603551D 0E041604 14D9812D C8317477
  8DE36BED 56E7EA12 238458C0 AB300D06 092A8648 86F70D01 01040500 03818100
  1D070628 97289B70 5232CF0F 90385491 EF2D1BE2 0727752A 26372174 9BFF2D8E
  48393ABB D1CFFFD3 3A3DD0F4 4129CC11 9889BD50 E34102AD 73D3350B 8AAED219
  CD2BA90C 27F10D8A A886305D D4FAE4D9 CFB58DFF A48F8A69 27794E02 CF2144EA
  EFCED9F0 6CFDFE4C 9CAE7CF0 97459580 093DC01C 35AB8559 4D0B04E0 40644CB3
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.8.8 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.8 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/20
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!      
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan8
 ip address 155.1.8.8 255.255.255.0
!
interface Vlan58
 ip address 155.1.58.8 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

-----------------------------------------------------------------------------------------------

SW3: 

Enable
Config t






Current configuration : 3831 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817305984
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817305984
 revocation-check none
 rsakeypair TP-self-signed-3817305984
!
!
crypto pki certificate chain TP-self-signed-3817305984
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 33303539 3834301E 170D3933 30333031 30303131
  30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313733
  30353938 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C769 FF6EFF61 B1A90633 742490B5 451DB6A8 FD3ECCEB D50F2A27 06A6ED45
  FE139569 A086D8B8 41C65CE6 94E798C7 A8DF051A 517916F6 FB95380A E47BFE44
  DDDB9A60 8ACEB1F7 CDA47FB2 6939B9D8 A6E3BF7C B824AC58 1519707F 018A6806
  9C246CFF 3C6A817F 2FFF8376 D496A0F6 606E7E0C F161678C A92800A1 DE884A97
  545F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535733 2E301F06 03551D23 04183016 8014727E F9FC8A5B
  863BBB1E BC2C115F 813F4BFC 9EA9301D 0603551D 0E041604 14727EF9 FC8A5B86
  3BBB1EBC 2C115F81 3F4BFC9E A9300D06 092A8648 86F70D01 01040500 03818100
  7AB609CE 03584B9A 85D00FCF 6CA6F59F E4984898 35D53691 6433BF57 A37C3ED1
  4866CBC1 E99C3746 799393CC 95EEE40A DD9F6A51 3F061CCF 3CB59A53 897AF112
  4F135059 01DA2695 3EC6DCAB 4C850371 72404BD0 3C15F2C5 926617EB 047E9D92
  65948CC2 DC676466 1194CB15 364D3665 088ABB44 0E5929DB 2F408387 1A704054
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.9.9 255.255.255.0
!      
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 43
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!      
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan9
 ip address 155.1.9.9 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.9 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end
-----------------------------------------------------------------------------------------------

SW4: 

Enable
Config t




Current configuration : 3800 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817290240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290240
 revocation-check none
 rsakeypair TP-self-signed-3817290240
!
!
crypto pki certificate chain TP-self-signed-3817290240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393032 3430301E 170D3933 30333031 30303131
  30325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A882 8FE6CF9A B3F50221 B8E72FCF 63CCCD43 C1A9413D 0FB9A949 7039AF7A
  C388A46C BAD51B80 8FF8E1D9 93117A25 7B3050AE B45DD0F1 BCF4A248 E8E67E26
  C32763D1 EEF76A8C CE39F76C 974AA287 D0822950 BB6ECD51 963A028D 9BD7B103
  E40BCA82 6CDA6BBF 11A9F479 53A4E74C 81B718D7 D02291BF F48444FB F3AE2205
  C8BD0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535734 2E301F06 03551D23 04183016 80141447 F24FD588
  D20BE6F5 CD962442 8F6EB9DA 9579301D 0603551D 0E041604 141447F2 4FD588D2
  0BE6F5CD 9624428F 6EB9DA95 79300D06 092A8648 86F70D01 01040500 03818100
  1CC19729 F5D312B9 DA3B6C4B 5AC0BD06 6317043C 05CF0A2B CDA4F23E 2D0E8A24
  2FB4DBF1 9551F6B2 469A7904 3FC08A0A 997DC725 5B00BDA8 5BA37247 B45E7086
  5CE14049 C1FC95BB F3D2CDC4 F68F8271 F71CED12 B3B0CFB1 658584DC F731F6B8
  7410BA9C E3819D52 4B36A44F B45094CF 669F6B6B 10C6FD9B 173FB472 E424132D
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.10.10 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.10 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!      
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/17
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end
----------------------------------------------------------------------------------

I will post the solution of this ticket once i get responses from you guys. Thanks.





OSPF TroubleShooting

OSPF TS is not that difficult it self but sometimes other underlying layer 2 technologies make the TS difficult. Lets take an OSPF Troubleshooting ticket. I deliberately introduce multiple issues in this topology. These issues may not necessarily be from OSPF.
You just need to copy and paste the initial configuration on concern devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes 

Topology Diagram: 

Ticket1: R1 and R2 are not forming ospf adjacency. Fix it. There can be multiple issue with this TS ticket.

--------------------INITIAL CONFIGURATIONS-------------------------

R1:


enable
config t



Current configuration : 1624 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 150.1.11.11 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/1.1 multipoint
 ip address 155.1.12.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 12 md5 CISC0
 ip ospf priority 0
 frame-relay map ip 155.1.12.2 201 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 router-id 150.1.1.1
 log-adjacency-changes
 area 12 nssa
 redistribute connected subnets route-map CONNECTED->OSPF
 network 150.1.1.1 0.0.0.0 area 1
 network 155.1.12.1 0.0.0.0 area 12
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!      
!
!
!
!
!
route-map CONNECTED->OSPF permit 10
 match interface Loopback1
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------
R2:

enable
config t

Current configuration : 1506 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!         
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface Loopback1
 ip address 150.1.22.22 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/1.1 multipoint
 ip address 155.1.12.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 12 md5 CISCO
 frame-relay map ip 155.1.12.1 201 
 no frame-relay inverse-arp
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 12 
 network 150.1.2.2 0.0.0.0 area 0
 network 155.1.12.2 0.0.0.0 area 12
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!         
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

--------------------------------------------------------------------------------------
R3:

enable
config t

Current configuration : 1330 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!         
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 clock rate 128000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/3 201
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 clock rate 128000
 frame-relay lmi-type cisco
 frame-relay route 211 interface Serial1/2 112
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!         
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end
        
------------------------------------------------------------------------------------

I will post the solution once i get response from you guys. Thanks

MPLS TroubleShooting

MPLS TS is something many of us fear with. Lets take a  troubleshooting ticket on MPLS to understand this technology in depth. I deliberately introduce multiple issues in this topology. These issues may not necessarily be from MPLS.
You just need to copy and paste the initial configuration on all the devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes

Topology Diagram:



Ticket:Vlan 7 is unable to reach Vlan 8. Fix it. There can be multiple issues in this TS ticket.


     ---------------------------INITIAL CONFIGURATIONS-------------------------

R1:


enable
conf t

Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.1 255.255.255.0
 frame-relay interface-dlci 105
!      
interface Serial0/0/1
 ip address 155.1.13.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!      
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end


--------------------------------------------------------------------------------------------------------------------
R2:


enable
config t



Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.2 255.255.255.0
 frame-relay interface-dlci 205
!
interface Serial0/0/1
 ip address 155.1.23.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------
R3:


enable
config t



Current configuration : 1410 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.3 255.255.255.0
 frame-relay interface-dlci 305
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 clock rate 64000
!
interface Serial1/3
 ip address 155.1.23.3 255.255.255.0
 clock rate 64000
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!      
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!      
scheduler allocate 20000 1000
end

------------------------------------------------------------------------------------------
R4:



enable
config t


Current configuration : 2866 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
no ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.5.5 password CISCO
mpls ldp neighbor 150.1.6.6 password cisco
no mpls ldp advertise-labels
mpls ldp advertise-labels for 11
mpls label protocol ldp
!
!
!
!
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!      
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 204.12.1.4 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 duplex auto
 speed auto
 mpls ip
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 shutdown
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.4 255.255.255.0
 frame-relay interface-dlci 405
!
interface Serial0/1
 ip address 155.1.45.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ldp discovery transport-address interface
 clock rate 64000
!
router ospf 100
 mpls ldp autoconfig area 0
 router-id 150.1.4.4
 log-adjacency-changes
 network 150.1.4.4 0.0.0.0 area 0
 network 155.1.45.4 0.0.0.0 area 0
 network 155.1.146.4 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.5.5 remote-as 100
 neighbor 150.1.5.5 password C1SCO
 neighbor 150.1.5.5 update-source Loopback0
 neighbor 150.1.6.6 remote-as 100
 neighbor 150.1.6.6 password CISCO
 neighbor 150.1.6.6 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.5.5 activate
  neighbor 150.1.5.5 route-reflector-client
  neighbor 150.1.6.6 activate
  neighbor 150.1.6.6 route-reflector-client
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.5.5 activate
  neighbor 150.1.5.5 send-community extended
  neighbor 150.1.5.5 route-reflector-client
  neighbor 150.1.6.6 activate
  neighbor 150.1.6.6 send-community extended
  exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------
R5:



enable
config t


Current configuration : 2723 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip vrf VPN_A
 rd 100:1
 route-target export 100:55
 route-target import 100:6
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
mpls label protocol tdp
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip vrf forwarding VPN_A
 ip address 155.1.58.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.5.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 shutdown
 frame-relay map ip 155.1.0.4 504 broadcast
 frame-relay map ip 155.1.0.3 503 broadcast
 frame-relay map ip 155.1.0.2 502 broadcast
 frame-relay map ip 155.1.0.1 501 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 155.1.45.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ldp discovery transport-address interface
 mpls ip
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 155.1.58.5 0.0.0.0 area 1
!
router ospf 100
 router-id 150.1.5.5
 log-adjacency-changes
 network 150.1.5.5 0.0.0.0 area 0
 network 155.1.45.5 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.4.4 remote-as 100
 neighbor 150.1.4.4 password CISCO
 neighbor 150.1.4.4 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.4.4 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.4.4 activate
  neighbor 150.1.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

--------------------------------------------------------------------------------------
R6:



enable
config t


Current configuration : 2599 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip vrf VPN_A
 rd 100:1
 route-target export 100:66
 route-target import 100:5
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
mpls label protocol ldp
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
!
interface FastEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ip
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 54.1.1.254 101 broadcast
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 network 155.1.67.6 0.0.0.0 area 1
!
router ospf 100
 router-id 150.1.6.6
 log-adjacency-changes
 network 150.1.6.6 0.0.0.0 area 0
 network 155.1.146.6 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.4.4 remote-as 100
 neighbor 150.1.4.4 password CISCO
 neighbor 150.1.4.4 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.4.4 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.4.4 activate
  neighbor 150.1.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  redistribute ospf 1 vrf VPN_A match internal external 1 external 2
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end    



SW1:


enable
config t



Current configuration : 4299 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
ip vrf VPN_A
 rd 100:1
!
!
!
crypto pki trustpoint TP-self-signed-3817290112
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290112
 revocation-check none
 rsakeypair TP-self-signed-3817290112
!
!
crypto pki certificate chain TP-self-signed-3817290112
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393031 3132301E 170D3933 30333031 30303435
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303131 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A620 7B67ACE8 75C8013C 497F0C2C AC6BB470 C378B292 C3404D98 A6BC8000
  5FB12A04 426C6B8A 1E20BCA6 684F3517 09098B66 BBA903C8 E5E867CF FEF40FF7
  2241342E E1A7F68D 0858F766 5FEE91B1 AD9CB7A6 A3310A06 651C0A3F C31916F7
  03C13FE5 4474A75D 8ADA6387 71626B99 86E7160A FF6CC129 D2C2B0CC 2E827A3C
  F72D0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535731 2E301F06 03551D23 04183016 801462B5 BF96E610
  33D9193C 83AEC52F 851B8630 BAEC301D 0603551D 0E041604 1462B5BF 96E61033
  D9193C83 AEC52F85 1B8630BA EC300D06 092A8648 86F70D01 01040500 03818100
  746BBA38 551BEA97 6DC1C56B 7F66F51A 84495B1A 9CB380FF D245D7C6 8C966D8E
  76F7DF51 4C87BF06 201AA184 CC4C4302 941B99AF 401550E4 7F6F20F3 3B56E5FE
  4D3AEC8C 4FF5A772 DB26E080 8F8B14A9 2C1A4A5C 112F5256 31795606 9B21DC59
  D477C754 B6769E3D 2E76463F F289AF38 812C3318 220EC1FC 42246570 8584C5CB
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!      
!
interface Loopback0
 ip vrf forwarding VPN_A
 ip address 150.1.7.7 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
 shutdown
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 58
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!      
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan7
 ip vrf forwarding VPN_A
 ip address 155.1.7.7 255.255.255.0
!
interface Vlan67
 ip vrf forwarding VPN_A
 ip address 155.1.67.7 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
!
interface Vlan79
 ip address 155.1.79.7 255.255.255.0
 shutdown
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 redistribute connected subnets route-map VL7CONNN->OSPF
 network 150.1.7.7 0.0.0.0 area 1
 network 155.1.67.7 0.0.0.0 area 1
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
route-map VL7CONN->OSPF permit 10
 match interface Vlan7
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

------------------------------------------------------------------------------------------------
SW2:


enable
config t



Current configuration : 4324 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1440
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-3819482240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3819482240
 revocation-check none
 rsakeypair TP-self-signed-3819482240
!
!
crypto pki certificate chain TP-self-signed-3819482240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383139 34383232 3430301E 170D3933 30333031 30303435
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313934
  38323234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CA94 74434DD0 75D58511 498BADEA 0A45DC20 3F694F06 7E526FC7 6816BF03
  B123D58B C0664B85 3466913F 57E14362 2A0D715F E6B8322A 799C4526 E1A68DCB
  9E13D4B1 3FAA06F7 CADF26FB 2CD01B2D EBA8E469 BFACCA4E 1481CCAC 25031980
  493F12FD A7C56CF4 1372AA34 BD058D42 64844DB4 D3829C4F 6587CBEC F58C3917
  EB9F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 80144BBF 74B7EF03
  5E15F7A7 FC3498AB 4694EB2F 3FE3301D 0603551D 0E041604 144BBF74 B7EF035E
  15F7A7FC 3498AB46 94EB2F3F E3300D06 092A8648 86F70D01 01040500 03818100
  7ABB1A9A 8AAFB5B5 1D969E4E B8DE398D 93DCECED 22FF0BF0 FE4BF86A 18D418E3
  9292616F 472C270C 67673622 EEDB6E5E 21C029EC 46F3160A 2AA1BF6A 22B52664
  D7F9C235 609DB9BA ABAFC3B1 425D4BE8 16BC5EEF 3ED6BE93 0097AF6F 23800429
  C6568D51 EDA2BFAA 0D7C4E96 8D5F91CF 1CCF696E B66252C3 68D16397 87CB705E
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.8.8 255.255.255.0
!
interface Port-channel1
 no switchport
 ip address 155.1.108.8 255.255.255.0
 shutdown
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 no switchport
 no ip address
 shutdown
 channel-group 1 mode on
!
interface FastEthernet0/20
 no switchport
 no ip address
 shutdown
 channel-group 1 mode on
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan8
 ip address 155.1.8.8 255.255.255.0
!
interface Vlan58
 ip address 155.1.58.8 255.255.255.0
 ip ospf authentication
 ip ospf message-digest-key 1 md5 CISCO
!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map VL8CONN->OSPF
 network 150.1.8.8 0.0.0.0 area 1
 network 155.1.58.8 0.0.0.0 area 1
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
route-map VL8CONN->OSPF permit 10
 match interface Vlan8
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

------------------------------------------------------------------------------------------------
SW3:


enable
config t



Current configuration : 3804 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817305984
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817305984
 revocation-check none
 rsakeypair TP-self-signed-3817305984
!
!
crypto pki certificate chain TP-self-signed-3817305984
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 33303539 3834301E 170D3933 30333031 30303435
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313733
  30353938 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BFD2 3AB861BF AB19D9E7 DAEF9CCA 217EC34E 8FB8B790 2F3A4AA3 1C24983B
  4047F4CB 643923A4 0C398FF3 F3C7BB9B 173BA28C E71DDE4C DD164EFE 38029524
  712B0408 A0038479 7CACDF1A 324B6DB4 FFFF4E8A 62F24AFE EDF1FB9A DE96EC16
  7F8A70D7 AA7C6A1E 31265008 40BBD4B6 537D0C02 F24E31EB 0AC38D5B D51B0D02
  38170203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535733 2E301F06 03551D23 04183016 801435BE 72A60831
  DD364141 50AB11F9 1D8127FE 09C1301D 0603551D 0E041604 1435BE72 A60831DD
  36414150 AB11F91D 8127FE09 C1300D06 092A8648 86F70D01 01040500 03818100
  132DCA88 EAC12D64 355CF32A 9815CC72 F137B8DD 3FE7703E BF8C7686 00D17D3B
  A8EF6001 004E66AB 02452BEB 1CE60FBE 9B6B7E1A 703CA63C CE572A39 6BA6033F
  58F19F8F 86C4CFC9 EE683BA8 2FF5F1BE AF526BDC 4D40FC95 175D910B 678E0A5D
  83294087 95A7E1F0 50EF2E96 C577E5A0 53F67230 52F83DB1 A47BCD24 F5EFD575
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.9.9 255.255.255.0
!      
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!      
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan9
 ip address 155.1.9.9 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.9 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

-----------------------------------------------------------------------------------------------
SW4:

enable
config t


Current configuration : 3800 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817290240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290240
 revocation-check none
 rsakeypair TP-self-signed-3817290240
!
!
crypto pki certificate chain TP-self-signed-3817290240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393032 3430301E 170D3933 30333031 30303435
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BFF6 E26A206A 1BB0653B 6AFD01DC 6CB0C476 44A05081 1F2D2C24 D4D2B7B6
  05F8EDCB 1B24822F 7FB2DA32 63D5BB0E 42A3B279 E390255D 49A82D9B 18CBF919
  C29B9873 2A0AEE3B 23A6538F 9AEF5561 B24B17CF 4C82AC63 463EA3DC 7C041FD2
  5DFE2EFC F268D364 E05079CA C20DD377 B3E08BD4 E4E3540E 6A7CAE54 BB285010
  1FD70203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535734 2E301F06 03551D23 04183016 801436FD EAF3DFF0
  CF4D3F67 32655B11 08EE5E9A 5825301D 0603551D 0E041604 1436FDEA F3DFF0CF
  4D3F6732 655B1108 EE5E9A58 25300D06 092A8648 86F70D01 01040500 03818100
  201D95D7 6D4A2F45 27D42AE8 4D68B11C F58143CC 37B76510 1CF1A4E3 805700DA
  C2BCD024 3B14D943 8CB27C6A C79E8C6F 3406AB30 BF77616C CD4FC059 81457DA8
  4BE48608 28DD7524 AA12226A 0C6CAF44 4F34CCD3 2996006D 8A35534C 034FAFDC
  5BC4817E 69AB3C87 BD87D800 83DF8F49 5F7E9486 4EBF9E77 12E416F5 97D56C9D
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.10.10 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.10 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!      
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/17
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

-------------------------------------------------------------------------------------------------

I will post the solution once i get response from you guys. Thanks