Wednesday, April 18, 2012

MPLS TroubleShooting

MPLS TS is something many of us fear with. Lets take a  troubleshooting ticket on MPLS to understand this technology in depth. I deliberately introduce multiple issues in this topology. These issues may not necessarily be from MPLS.
You just need to copy and paste the initial configuration on all the devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes

Topology Diagram:



Ticket:Vlan 7 is unable to reach Vlan 8. Fix it. There can be multiple issues in this TS ticket.


     ---------------------------INITIAL CONFIGURATIONS-------------------------

R1:


enable
conf t

Current configuration : 1285 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.146.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.1 255.255.255.0
 frame-relay interface-dlci 105
!      
interface Serial0/0/1
 ip address 155.1.13.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!      
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end


--------------------------------------------------------------------------------------------------------------------
R2:


enable
config t



Current configuration : 1274 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.10.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.2 255.255.255.0
 frame-relay interface-dlci 205
!
interface Serial0/0/1
 ip address 155.1.23.2 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!      
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

-----------------------------------------------------------------------------------------------
R3:


enable
config t



Current configuration : 1410 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!      
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
!
interface FastEthernet0/0
 ip address 155.1.37.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
!
interface Serial1/0.1 point-to-point
 ip address 155.1.0.3 255.255.255.0
 frame-relay interface-dlci 305
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 ip address 155.1.13.3 255.255.255.0
 clock rate 64000
!
interface Serial1/3
 ip address 155.1.23.3 255.255.255.0
 clock rate 64000
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
!      
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!      
scheduler allocate 20000 1000
end

------------------------------------------------------------------------------------------
R4:



enable
config t


Current configuration : 2866 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
no ip cef
!      
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.5.5 password CISCO
mpls ldp neighbor 150.1.6.6 password cisco
no mpls ldp advertise-labels
mpls ldp advertise-labels for 11
mpls label protocol ldp
!
!
!
!
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!      
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 204.12.1.4 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.146.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 duplex auto
 speed auto
 mpls ip
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 shutdown
!
interface Serial0/0/0.1 point-to-point
 ip address 155.1.0.4 255.255.255.0
 frame-relay interface-dlci 405
!
interface Serial0/1
 ip address 155.1.45.4 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ldp discovery transport-address interface
 clock rate 64000
!
router ospf 100
 mpls ldp autoconfig area 0
 router-id 150.1.4.4
 log-adjacency-changes
 network 150.1.4.4 0.0.0.0 area 0
 network 155.1.45.4 0.0.0.0 area 0
 network 155.1.146.4 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.5.5 remote-as 100
 neighbor 150.1.5.5 password C1SCO
 neighbor 150.1.5.5 update-source Loopback0
 neighbor 150.1.6.6 remote-as 100
 neighbor 150.1.6.6 password CISCO
 neighbor 150.1.6.6 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.5.5 activate
  neighbor 150.1.5.5 route-reflector-client
  neighbor 150.1.6.6 activate
  neighbor 150.1.6.6 route-reflector-client
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.5.5 activate
  neighbor 150.1.5.5 send-community extended
  neighbor 150.1.5.5 route-reflector-client
  neighbor 150.1.6.6 activate
  neighbor 150.1.6.6 send-community extended
  exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------------------
R5:



enable
config t


Current configuration : 2723 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip vrf VPN_A
 rd 100:1
 route-target export 100:55
 route-target import 100:6
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
mpls label protocol tdp
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.5.5 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip vrf forwarding VPN_A
 ip address 155.1.58.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 155.1.5.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 155.1.0.5 255.255.255.0
 encapsulation frame-relay
 shutdown
 frame-relay map ip 155.1.0.4 504 broadcast
 frame-relay map ip 155.1.0.3 503 broadcast
 frame-relay map ip 155.1.0.2 502 broadcast
 frame-relay map ip 155.1.0.1 501 broadcast
 no frame-relay inverse-arp
!
interface Serial0/1
 ip address 155.1.45.5 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ldp discovery transport-address interface
 mpls ip
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 155.1.58.5 0.0.0.0 area 1
!
router ospf 100
 router-id 150.1.5.5
 log-adjacency-changes
 network 150.1.5.5 0.0.0.0 area 0
 network 155.1.45.5 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.4.4 remote-as 100
 neighbor 150.1.4.4 password CISCO
 neighbor 150.1.4.4 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.4.4 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.4.4 activate
  neighbor 150.1.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end

--------------------------------------------------------------------------------------
R6:



enable
config t


Current configuration : 2599 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password cisco
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
ip vrf VPN_A
 rd 100:1
 route-target export 100:66
 route-target import 100:5
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
mpls ldp password required
mpls ldp neighbor 150.1.4.4 password CISCO
no mpls ldp advertise-labels
mpls ldp advertise-labels for 1
mpls label protocol ldp
!
!
!
!      
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.67
 encapsulation dot1Q 67
 ip address 155.1.67.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
!
interface FastEthernet0/0.146
 encapsulation dot1Q 146
 ip address 155.1.146.6 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
 mpls ip
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 54.1.1.6 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 54.1.1.254 101 broadcast
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 network 155.1.67.6 0.0.0.0 area 1
!
router ospf 100
 router-id 150.1.6.6
 log-adjacency-changes
 network 150.1.6.6 0.0.0.0 area 0
 network 155.1.146.6 0.0.0.0 area 0
!
router bgp 100
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 150.1.4.4 remote-as 100
 neighbor 150.1.4.4 password CISCO
 neighbor 150.1.4.4 update-source Loopback0
 !
 address-family ipv4
  neighbor 150.1.4.4 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family vpnv4
  neighbor 150.1.4.4 activate
  neighbor 150.1.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
  redistribute ospf 1 vrf VPN_A match internal external 1 external 2
  no synchronization
 exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
access-list 1 permit 150.1.0.0 0.0.255.255
!
!
!
!
!
mpls ldp router-id Loopback0 force
!
control-plane
!      
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line aux 0
 exec-timeout 0 0
 privilege level 15
line vty 0 4
 password cisco
 login
!
scheduler allocate 20000 1000
end    



SW1:


enable
config t



Current configuration : 4299 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
ip vrf VPN_A
 rd 100:1
!
!
!
crypto pki trustpoint TP-self-signed-3817290112
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290112
 revocation-check none
 rsakeypair TP-self-signed-3817290112
!
!
crypto pki certificate chain TP-self-signed-3817290112
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393031 3132301E 170D3933 30333031 30303435
  33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303131 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100A620 7B67ACE8 75C8013C 497F0C2C AC6BB470 C378B292 C3404D98 A6BC8000
  5FB12A04 426C6B8A 1E20BCA6 684F3517 09098B66 BBA903C8 E5E867CF FEF40FF7
  2241342E E1A7F68D 0858F766 5FEE91B1 AD9CB7A6 A3310A06 651C0A3F C31916F7
  03C13FE5 4474A75D 8ADA6387 71626B99 86E7160A FF6CC129 D2C2B0CC 2E827A3C
  F72D0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535731 2E301F06 03551D23 04183016 801462B5 BF96E610
  33D9193C 83AEC52F 851B8630 BAEC301D 0603551D 0E041604 1462B5BF 96E61033
  D9193C83 AEC52F85 1B8630BA EC300D06 092A8648 86F70D01 01040500 03818100
  746BBA38 551BEA97 6DC1C56B 7F66F51A 84495B1A 9CB380FF D245D7C6 8C966D8E
  76F7DF51 4C87BF06 201AA184 CC4C4302 941B99AF 401550E4 7F6F20F3 3B56E5FE
  4D3AEC8C 4FF5A772 DB26E080 8F8B14A9 2C1A4A5C 112F5256 31795606 9B21DC59
  D477C754 B6769E3D 2E76463F F289AF38 812C3318 220EC1FC 42246570 8584C5CB
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!      
!
interface Loopback0
 ip vrf forwarding VPN_A
 ip address 150.1.7.7 255.255.255.0
!
interface FastEthernet0/1
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 no switchport
 ip address 155.1.37.7 255.255.255.0
 shutdown
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 58
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!      
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan7
 ip vrf forwarding VPN_A
 ip address 155.1.7.7 255.255.255.0
!
interface Vlan67
 ip vrf forwarding VPN_A
 ip address 155.1.67.7 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 CISCO
!
interface Vlan79
 ip address 155.1.79.7 255.255.255.0
 shutdown
!
router ospf 1 vrf VPN_A
 log-adjacency-changes
 redistribute connected subnets route-map VL7CONNN->OSPF
 network 150.1.7.7 0.0.0.0 area 1
 network 155.1.67.7 0.0.0.0 area 1
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
route-map VL7CONN->OSPF permit 10
 match interface Vlan7
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

------------------------------------------------------------------------------------------------
SW2:


enable
config t



Current configuration : 4324 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1440
authentication mac-move permit
ip subnet-zero
ip routing
no ip domain-lookup
!
!
!
!
crypto pki trustpoint TP-self-signed-3819482240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3819482240
 revocation-check none
 rsakeypair TP-self-signed-3819482240
!
!
crypto pki certificate chain TP-self-signed-3819482240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383139 34383232 3430301E 170D3933 30333031 30303435
  33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313934
  38323234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CA94 74434DD0 75D58511 498BADEA 0A45DC20 3F694F06 7E526FC7 6816BF03
  B123D58B C0664B85 3466913F 57E14362 2A0D715F E6B8322A 799C4526 E1A68DCB
  9E13D4B1 3FAA06F7 CADF26FB 2CD01B2D EBA8E469 BFACCA4E 1481CCAC 25031980
  493F12FD A7C56CF4 1372AA34 BD058D42 64844DB4 D3829C4F 6587CBEC F58C3917
  EB9F0203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535732 2E301F06 03551D23 04183016 80144BBF 74B7EF03
  5E15F7A7 FC3498AB 4694EB2F 3FE3301D 0603551D 0E041604 144BBF74 B7EF035E
  15F7A7FC 3498AB46 94EB2F3F E3300D06 092A8648 86F70D01 01040500 03818100
  7ABB1A9A 8AAFB5B5 1D969E4E B8DE398D 93DCECED 22FF0BF0 FE4BF86A 18D418E3
  9292616F 472C270C 67673622 EEDB6E5E 21C029EC 46F3160A 2AA1BF6A 22B52664
  D7F9C235 609DB9BA ABAFC3B1 425D4BE8 16BC5EEF 3ED6BE93 0097AF6F 23800429
  C6568D51 EDA2BFAA 0D7C4E96 8D5F91CF 1CCF696E B66252C3 68D16397 87CB705E
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.8.8 255.255.255.0
!
interface Port-channel1
 no switchport
 ip address 155.1.108.8 255.255.255.0
 shutdown
!
interface FastEthernet0/1
!
interface FastEthernet0/2
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 no switchport
 no ip address
 shutdown
 channel-group 1 mode on
!
interface FastEthernet0/20
 no switchport
 no ip address
 shutdown
 channel-group 1 mode on
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 22
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan8
 ip address 155.1.8.8 255.255.255.0
!
interface Vlan58
 ip address 155.1.58.8 255.255.255.0
 ip ospf authentication
 ip ospf message-digest-key 1 md5 CISCO
!
router ospf 1
 log-adjacency-changes
 redistribute connected subnets route-map VL8CONN->OSPF
 network 150.1.8.8 0.0.0.0 area 1
 network 155.1.58.8 0.0.0.0 area 1
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
route-map VL8CONN->OSPF permit 10
 match interface Vlan8
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

------------------------------------------------------------------------------------------------
SW3:


enable
config t



Current configuration : 3804 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW3
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817305984
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817305984
 revocation-check none
 rsakeypair TP-self-signed-3817305984
!
!
crypto pki certificate chain TP-self-signed-3817305984
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 33303539 3834301E 170D3933 30333031 30303435
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313733
  30353938 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BFD2 3AB861BF AB19D9E7 DAEF9CCA 217EC34E 8FB8B790 2F3A4AA3 1C24983B
  4047F4CB 643923A4 0C398FF3 F3C7BB9B 173BA28C E71DDE4C DD164EFE 38029524
  712B0408 A0038479 7CACDF1A 324B6DB4 FFFF4E8A 62F24AFE EDF1FB9A DE96EC16
  7F8A70D7 AA7C6A1E 31265008 40BBD4B6 537D0C02 F24E31EB 0AC38D5B D51B0D02
  38170203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535733 2E301F06 03551D23 04183016 801435BE 72A60831
  DD364141 50AB11F9 1D8127FE 09C1301D 0603551D 0E041604 1435BE72 A60831DD
  36414150 AB11F91D 8127FE09 C1300D06 092A8648 86F70D01 01040500 03818100
  132DCA88 EAC12D64 355CF32A 9815CC72 F137B8DD 3FE7703E BF8C7686 00D17D3B
  A8EF6001 004E66AB 02452BEB 1CE60FBE 9B6B7E1A 703CA63C CE572A39 6BA6033F
  58F19F8F 86C4CFC9 EE683BA8 2FF5F1BE AF526BDC 4D40FC95 175D910B 678E0A5D
  83294087 95A7E1F0 50EF2E96 C577E5A0 53F67230 52F83DB1 A47BCD24 F5EFD575
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.9.9 255.255.255.0
!      
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!      
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 switchport mode dynamic desirable
!
interface FastEthernet0/17
 switchport mode dynamic desirable
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 43
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan9
 ip address 155.1.9.9 255.255.255.0
!
interface Vlan79
 ip address 155.1.79.9 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

-----------------------------------------------------------------------------------------------
SW4:

enable
config t


Current configuration : 3800 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack1SW4
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
!
!
no aaa new-model
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!      
!
!
!
crypto pki trustpoint TP-self-signed-3817290240
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3817290240
 revocation-check none
 rsakeypair TP-self-signed-3817290240
!
!
crypto pki certificate chain TP-self-signed-3817290240
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383137 32393032 3430301E 170D3933 30333031 30303435
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38313732
  39303234 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BFF6 E26A206A 1BB0653B 6AFD01DC 6CB0C476 44A05081 1F2D2C24 D4D2B7B6
  05F8EDCB 1B24822F 7FB2DA32 63D5BB0E 42A3B279 E390255D 49A82D9B 18CBF919
  C29B9873 2A0AEE3B 23A6538F 9AEF5561 B24B17CF 4C82AC63 463EA3DC 7C041FD2
  5DFE2EFC F268D364 E05079CA C20DD377 B3E08BD4 E4E3540E 6A7CAE54 BB285010
  1FD70203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04535734 2E301F06 03551D23 04183016 801436FD EAF3DFF0
  CF4D3F67 32655B11 08EE5E9A 5825301D 0603551D 0E041604 1436FDEA F3DFF0CF
  4D3F6732 655B1108 EE5E9A58 25300D06 092A8648 86F70D01 01040500 03818100
  201D95D7 6D4A2F45 27D42AE8 4D68B11C F58143CC 37B76510 1CF1A4E3 805700DA
  C2BCD024 3B14D943 8CB27C6A C79E8C6F 3406AB30 BF77616C CD4FC059 81457DA8
  4BE48608 28DD7524 AA12226A 0C6CAF44 4F34CCD3 2996006D 8A35534C 034FAFDC
  5BC4817E 69AB3C87 BD87D800 83DF8F49 5F7E9486 4EBF9E77 12E416F5 97D56C9D
  quit
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface Loopback0
 ip address 150.1.10.10 255.255.255.0
!      
interface Port-channel1
 no switchport
 ip address 155.1.108.10 255.255.255.0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
 switchport access vlan 146
 switchport mode access
 spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!      
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 switchport mode dynamic desirable
!
interface FastEthernet0/14
 switchport mode dynamic desirable
!
interface FastEthernet0/15
 switchport mode dynamic desirable
!
interface FastEthernet0/16
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/17
 no switchport
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/18
 switchport mode dynamic desirable
!
interface FastEthernet0/19
 switchport mode dynamic desirable
!
interface FastEthernet0/20
 switchport mode dynamic desirable
!
interface FastEthernet0/21
 switchport mode dynamic desirable
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 155.1.10.10 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 speed 38400
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
end

-------------------------------------------------------------------------------------------------

I will post the solution once i get response from you guys. Thanks














No comments: