Wednesday, April 18, 2012

OSPF TroubleShooting

OSPF TS is not that difficult it self but sometimes other underlying layer 2 technologies make the TS difficult. Lets take an OSPF Troubleshooting ticket. I deliberately introduce multiple issues in this topology. These issues may not necessarily be from OSPF.
You just need to copy and paste the initial configuration on concern devices of any INE Rack and start working on the TS ticket.

Note: You just need to take care of rack number. Here I have used Rack 1 .
Note: TRY NOT TO USE "Show run" commands for better learning purposes 

Topology Diagram: 

Ticket1: R1 and R2 are not forming ospf adjacency. Fix it. There can be multiple issue with this TS ticket.

--------------------INITIAL CONFIGURATIONS-------------------------

R1:


enable
config t



Current configuration : 1624 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!      
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!      
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 150.1.11.11 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/1.1 multipoint
 ip address 155.1.12.1 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 12 md5 CISC0
 ip ospf priority 0
 frame-relay map ip 155.1.12.2 201 broadcast
 no frame-relay inverse-arp
!
router ospf 1
 router-id 150.1.1.1
 log-adjacency-changes
 area 12 nssa
 redistribute connected subnets route-map CONNECTED->OSPF
 network 150.1.1.1 0.0.0.0 area 1
 network 155.1.12.1 0.0.0.0 area 12
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!      
!
!
!
!
!
route-map CONNECTED->OSPF permit 10
 match interface Loopback1
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

---------------------------------------------------------------------------------
R2:

enable
config t

Current configuration : 1506 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!         
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
!
interface Loopback1
 ip address 150.1.22.22 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
interface Serial0/0/1
 no ip address
 encapsulation frame-relay
!
interface Serial0/0/1.1 multipoint
 ip address 155.1.12.2 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 12 md5 CISCO
 frame-relay map ip 155.1.12.1 201 
 no frame-relay inverse-arp
!
router ospf 1
 router-id 150.1.2.2
 log-adjacency-changes
 area 12 
 network 150.1.2.2 0.0.0.0 area 0
 network 155.1.12.2 0.0.0.0 area 12
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!         
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end

--------------------------------------------------------------------------------------
R3:

enable
config t

Current configuration : 1330 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
ip cef
!
!         
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!         
!
!
!
!
voice-card 0
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial1/0
 no ip address
 shutdown
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 encapsulation frame-relay
 clock rate 128000
 frame-relay lmi-type ansi
 frame-relay intf-type dce
 frame-relay route 102 interface Serial1/3 201
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 clock rate 128000
 frame-relay lmi-type cisco
 frame-relay route 211 interface Serial1/2 112
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!         
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 speed 38400
line aux 0
line vty 0 4
 login
!
scheduler allocate 20000 1000
end
        
------------------------------------------------------------------------------------

I will post the solution once i get response from you guys. Thanks

No comments: